Bug 948370

Summary: One-Click-Installer YMP file cannot match group section for Tumbleweed
Product: [openSUSE] openSUSE Tumbleweed Reporter: Thomas Göttlicher <tgoettlicher>
Component: YaST2Assignee: YaST Team <yast-internal>
Status: RESOLVED WONTFIX QA Contact: Jiri Srain <jsrain>
Severity: Normal    
Priority: P5 - None CC: ancor
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: openSUSE 13.2   
URL: https://trello.com/c/214Yk4qI
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Thomas Göttlicher 2015-10-01 08:46:11 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build Identifier: 

One-Click-Installer YMP files can contain sections for different distribution versions, e.g.:
<group distversion="openSUSE 13.2">

You can match against a specific Tumbleweed build:
<group distversion="openSUSE 20150924">

But it's not possible to match for Tumbleweed in general because the version of Tumbleweed changes with every build.

Can the one-click-installer be extended to not only match against the version but also against the codename?

For example:
<group distcodename="openSUSE Tumbleweed">


Reproducible: Always
Comment 1 Ancor Gonzalez Sosa 2015-10-09 08:59:10 UTC
Added to YaST Team Scrum queue.
Comment 2 Stefan Hundhammer 2022-08-23 09:33:47 UTC
This is now 6 years old with no activity, so realistically this has been a WONTFIX during all that time. Closing.