Bug 637694

Summary: Split glade3 catalogs in subpackages
Product: [openSUSE] openSUSE 11.4 Reporter: Vincent Untz <vuntz>
Component: GNOMEAssignee: E-mail List <gnome-bugs>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None    
Version: Factory   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Vincent Untz 2010-09-08 00:08:53 UTC
We should grep for glade3 in all GNOME spec files and make all packages that ship a glade3 catalog (at least vte and gnome-media do, iirc) have a glade3-catalog-PACKAGE subpackage.

Those subpackages should not require anything, but they should have a Supplements(glade3:PACKAGE-devel). The rationale is that the files there don't have any real dependencies, but they come useful if the user is a developer and has glade3. An alternative could be to make them require or recommend the devel subpackage.
Comment 1 Vincent Untz 2010-10-05 13:53:50 UTC
evolution also has a catalog.

vte is waiting in home:vuntz:branches:GNOME:Factory (see bug 634199). gnome-media and evolution are being submitted to G:F.
Comment 2 Vincent Untz 2010-10-05 21:22:07 UTC
Still to do: anjuta, gtksourceview, libgnomedb (but it's being killed), libxfce4ui.
Comment 3 Vincent Untz 2010-10-05 22:19:00 UTC
(In reply to comment #2)
> Still to do: anjuta, gtksourceview, libgnomedb (but it's being killed),
> libxfce4ui.

All submitted, except libgnomedb.
Comment 4 Vincent Untz 2010-10-08 10:13:40 UTC
Done in G:F.
Comment 5 Swamp Workflow Management 2019-08-05 10:10:31 UTC
This is an autogenerated message for OBS integration:
This bug (637694) was mentioned in
https://build.opensuse.org/request/show/720992 Backports:SLE-12-SP2 / exo+libgarcon+libxfce4ui+libxfce4util+perl-ExtUtils-Depends+perl-ExtUtils-PkgConfig+perl-Glib+thunar+xfce4-dev-tools+xfce4-panel+xfconf
Comment 6 Swamp Workflow Management 2019-10-10 19:11:41 UTC
openSUSE-RU-2019:2305-1: An update that solves one vulnerability and has 10 fixes is now available.

Category: recommended (moderate)
Bug References: 1011518,1047218,1135362,637694,687874,760492,764310,767145,829113,860479,952324
CVE References: CVE-2011-1588
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    exo-0.12.0-2.1, libgarcon-0.6.1-2.1, libxfce4ui-4.12.1-2.1, libxfce4util-4.12.1-2.1, perl-ExtUtils-Depends-0.405-2.1, perl-ExtUtils-PkgConfig-1.160000-2.1, perl-Glib-1.326-2.1, thunar-1.6.14-2.1, xfce4-dev-tools-4.12.0-2.1, xfce4-panel-4.12.2-2.1, xfconf-4.12.1-2.1