Bug 1170971

Summary: missing dependencies for PlayOnLinux
Product: [openSUSE] openSUSE Tumbleweed Reporter: John Neo <john_neo>
Component: OtherAssignee: Eric Schirra <ecsos>
Status: RESOLVED INVALID QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: alynx.zhou, gianfrus, gm.venekamp, trekjunky
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: SUSE Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: Screenshot installing Playonlinux on OSL 15.4 through YaST

Description John Neo 2020-05-01 08:34:17 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0
Build Identifier: 

When I try to install PlayOnLinux with the following command :

# zypper in PlayOnLinux,

I receive issue with following message :

# nothing provides dbus-1-python needed by PlayOnLinux-4.3.4-21.4.noarch

Reproducible: Always

Steps to Reproduce:
1.# zypper in PlayOnLinux
2.
3.
Actual Results:  
# nothing provides dbus-1-python needed by PlayOnLinux-4.3.4-21.4.noarch

Expected Results:  
Installation finish successfully
Comment 1 Cane Kostovski 2020-05-12 05:17:55 UTC
I have OpenSuSE Tumble Weed with the exact same issue. I have tried installing it breaking the dependencies and got error messages when launching PlayOnLinux. I have since uninstalled it and tried just now to install it again, but it no longer appears in the repos lists, so I can't provide the errors. Something about Python2 errors.
Comment 2 Cane Kostovski 2020-05-14 07:05:02 UTC
So, any indication when this will be resolved? I hate to go back to Leap 15.1, but if you don't fix it soon, I will have to downgrade to Leap
Comment 3 G.M. Venekamp 2020-05-18 13:18:49 UTC
I am affected by this too. Held back a few updates, but had over 1200 updates pending. I use PlayOnLinux to get a VPN token for work.
Comment 4 John Neo 2020-05-24 16:04:50 UTC
There is new version on the website of PlayOnLInux and there is rpm package for Fedora.

http://repository.playonlinux.com/PlayOnLinux/4.4/

http://repository.playonlinux.com/PlayOnLinux/4.4/PlayOnLinux_4.4.rpm .

Do you think that OpenSuse team will build new version soon?
Comment 5 Eric Schirra 2021-09-14 07:44:12 UTC
This should be fixed in Tumbleweed, because dbus-1-python is only required for Leap.
%if 0%{?suse_version} <= 1500
Requires:       dbus-1-python
%endif
Comment 6 Gianluca Frustagli 2022-09-28 10:16:17 UTC
Hi, there hasn't been a bug fix yet.

I can confirm that the problem is still present in OpenSUSE Leap 15.4.
Comment 7 Eric Schirra 2022-09-28 13:17:36 UTC
This has been fixed since June 8, 2022

-------------------------------------------------------------------
Wed Jun  8 18:54:27 UTC 2022 - ecsos <ecsos@opensuse.org>
- Remove required python2 package dbus-1-python from spec.

Also, a test has just been successful.
No errors.
PlayOnLinux is installed.
Comment 8 Gianluca Frustagli 2022-09-28 13:57:43 UTC
Created attachment 861817 [details]
Screenshot installing Playonlinux on OSL 15.4 through YaST
Comment 9 Gianluca Frustagli 2022-09-28 14:00:46 UTC
Comment on attachment 861817 [details]
Screenshot installing Playonlinux on OSL 15.4 through YaST

...well, so we have a little mystery.
Please, take a look at the screenshot.
Comment 10 Eric Schirra 2022-09-28 14:37:18 UTC
No mystery.
This bug entry is about Tumbleweed.
You are talking about Leap.
Just install from game:tools if the package from Leap doesn't know it yet. Or just ignore it.
Or make a new bug entry.
Comment 11 Gianluca Frustagli 2022-09-28 16:08:35 UTC
(In reply to Eric Schirra from comment #10)
> No mystery.
> This bug entry is about Tumbleweed.
> You are talking about Leap.
> Just install from game:tools if the package from Leap doesn't know it yet.
> Or just ignore it.
> Or make a new bug entry.

Ok. Sorry for the misunderstanding. I could make a new bug entry.