Bug 1169509

Summary: [Ruby2.7] swig fails to build against ruby 2.7
Product: [openSUSE] openSUSE Tumbleweed Reporter: Dominique Leuenberger <dimstar>
Component: DevelopmentAssignee: Klaus Kämpf <kkaempf>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None    
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Bug Depends on:    
Bug Blocks: 1169435    

Description Dominique Leuenberger 2020-04-15 07:38:11 UTC
openSUSE Tumbleweed is in progress of moving to Ruby 2.7

swig is amongst the packages failing to build in Staging:L

https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:L/swig/standard/x86_64
Comment 1 Klaus Kämpf 2020-04-15 10:18:54 UTC
https://build.opensuse.org/request/show/794144
Comment 2 Dominique Leuenberger 2020-04-17 08:35:56 UTC
(In reply to Klaus Kämpf from comment #1)
> https://build.opensuse.org/request/show/794144

Was forwarded and accepted to Factory - Staging:L rebased and retested:
swig still failing:

https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:L/swig/standard/x86_64
Comment 3 Dominique Leuenberger 2020-04-17 08:41:37 UTC
(In reply to Dominique Leuenberger from comment #2)
> (In reply to Klaus Kämpf from comment #1)
> > https://build.opensuse.org/request/show/794144
> 
> Was forwarded and accepted to Factory - Staging:L rebased and retested:
> swig still failing:

Hmm. despite :L being rebased it is apparently building an old branch; will retry that again (a local branch seems to be ok)