Bug 1168937

Summary: [DuplicateBinaries] protoc-gen-go created by two sources
Product: [openSUSE] openSUSE Tumbleweed Reporter: Dominique Leuenberger <dimstar>
Component: OtherAssignee: Jeff Kowalczyk <jkowalczyk>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Major    
Priority: P2 - High CC: asarai, fcastelli, graham, jmassaguerpla
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Dominique Leuenberger 2020-04-08 07:10:00 UTC
There are currently two source packages producing a protoc-gen-go binary package. This is not supported inside OBS and results in only one (random) version to be published in the repository.

Duplicate binaries detected:

x86_64:
  protoc-gen-go:
  - protoc-gen-go
  - golang-github-golang-protobuf
Comment 1 Jeff Kowalczyk 2020-04-08 14:57:57 UTC
Thank for reporting this, I'll address it.
Comment 2 Dominique Leuenberger 2020-11-09 14:51:19 UTC
*** Bug 1178115 has been marked as a duplicate of this bug. ***
Comment 3 Dominique Leuenberger 2022-10-26 10:57:59 UTC
golang-github-golang-protobuf was removed in 2021 - which solved this issue

r2 | dimstar_suse | 2021-11-03 16:26:37 | 44eacbdf0a3ddab13972493def7d990c | 1.3.0 | rq929028

nothing provides golang(golang.org/x/sync/errgroup)