Bug 1099800

Summary: [Build 20180629] LxQT does not start up session, but asks for WM
Product: [openSUSE] openSUSE Tumbleweed Reporter: Dominique Leuenberger <dimstar>
Component: OtherAssignee: Michael Vetter <mvetter>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: dimstar, mvetter
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://openqa.opensuse.org/tests/699977/modules/reboot_icewm/steps/8
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: xdg-environment.sh change

Description Dominique Leuenberger 2018-07-02 07:00:57 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-otherDE_lxqt@64bit fails in
[reboot_icewm](https://openqa.opensuse.org/tests/699977/modules/reboot_icewm/steps/8)


## Reproducible

Fails since (at least) Build [20180629](https://openqa.opensuse.org/tests/699706)


## Expected result

Last good: [20180628](https://openqa.opensuse.org/tests/698941) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?machine=64bit&test=otherDE_lxqt&flavor=NET&version=Tumbleweed&arch=x86_64&distri=opensuse)

The installation is performed atop of a minimalX installation, then further installing the LXQt pattern. Until recently, this resulted in a functional LXQt desktop.

Now, LXQt asks for a Window Managed upon first start
Comment 1 Dominique Leuenberger 2018-07-02 07:02:28 UTC
The change in snapshot 0629 was the upgrade of LXQt to version 0.13.0
Comment 2 Michael Vetter 2018-07-04 10:45:09 UTC
This probably is due to LXQt changing the default configuration paths from eg /etc/xdg/lxqt/lxqt.conf to /usr/share/lxqt.conf

AFAIK the binary should check both locations.

On my system where I upgraded from an old installatoin it probably just uses the old configuration files in /etc.

On the new install where the configs are only in /usr/share it seems not to detect them.

Have to find out how the looking for configs is done, maybe it's some XDG variable.
Comment 3 Michael Vetter 2018-07-05 10:42:01 UTC
Created attachment 776192 [details]
xdg-environment.sh change

It seems LXQt looks at XDG_CONFIG_DIRS/lxqt.
E.g.: XDG_CONFIG_DIRS/lxqt/lxqt.conf, XDG_CONFIG_DIRS/lxqt/panel.conf, XDG_CONFIG_DIRS/lxqt/session.conf

When adding /usr/share to XDG_CONFIG_DIRS in /etc/profile.d/xdg-environment.sh it works as expected.

However I'm not sure this is a good solution. So far /usr/share is only in XDG_DATA_DIRS.

Dominique, what do you think?
Comment 5 Dominique Leuenberger 2018-07-23 13:15:29 UTC
Discussed on IRC

short summary:
I don't think adding /usr/share to XDG_CONFIG_DIR is a good idea

LXQt should either install it's config files to /usr/share OR (even better) have the code look in XDG_CONFIG_DIRS and if no useful config found there, fall back to XDG_DATA_DIR (which would mean /usr/share is only used if the user did not create local config files in /etc)
Comment 6 Michael Vetter 2018-07-24 08:58:47 UTC
In an effort to make it easier for distributions to ship customized config files  in /etc, LXQt upstream decided to move their default config files to the new location.

However the way they looked for this was not default in distros as the environment variables were different or not set.

Simon Quigley (Ubuntu maintainer) proposed [1] a patch to make LXQt check all the directories in case a distribution hasnt them all in the environment variable so far. Patch was declined but I think actually it is a good idea to use it.

1: https://github.com/lxqt/lxqt-session/pull/126
Comment 7 Michael Vetter 2018-07-24 09:02:10 UTC
SR#624971
Comment 8 Swamp Workflow Management 2018-07-24 09:40:17 UTC
This is an autogenerated message for OBS integration:
This bug (1099800) was mentioned in
https://build.opensuse.org/request/show/624971 Factory / lxqt-session
Comment 9 Michael Vetter 2018-08-02 11:25:15 UTC
Issue seems to be solved: https://openqa.opensuse.org/tests/717419
Comment 10 Swamp Workflow Management 2018-10-23 17:00:16 UTC
This is an autogenerated message for OBS integration:
This bug (1099800) was mentioned in
https://build.opensuse.org/request/show/644002 Factory / lxqt-session
Comment 11 Swamp Workflow Management 2019-01-31 16:10:20 UTC
This is an autogenerated message for OBS integration:
This bug (1099800) was mentioned in
https://build.opensuse.org/request/show/670395 Factory / lxqt-session