Bug 1099589

Summary: VirtualBox forgets status bar and toolbar
Product: [openSUSE] openSUSE Tumbleweed Reporter: Arno Frausenbruck <frausenbruck>
Component: Virtualization:ToolsAssignee: Larry Finger <Larry.Finger>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: frausenbruck, virt-bugs, wbauer
Version: CurrentFlags: Larry.Finger: needinfo? (frausenbruck)
Target Milestone: ---   
Hardware: Other   
OS: Other   
See Also: http://bugzilla.opensuse.org/show_bug.cgi?id=1099752
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Arno Frausenbruck 2018-06-28 22:19:01 UTC
After the latest Tumbleweed update/upgrade, the VirtualBox GUI forgets that I activated the status bar: 

The GUI now starts without the bars. I can still activate the bars via a right-click. If I now restart the GUI, it shows up again without the toolbar and the status bar.

I've tried to change the corresponding settings in the file ".VirtualBox/VirtualBox.xml". This works, but as soon as I quit the GUI, it resets my settings in the VirtualBox.xml.

So now I have to activate the toolbar and the status bar after each start of the VirtualBox GUI.
Comment 1 Andreas Stieger 2018-06-29 07:27:45 UTC
(In reply to Arno Frausenbruck from comment #0)
> After the latest Tumbleweed update/upgrade

Which one?
Comment 2 Arno Frausenbruck 2018-06-29 09:31:50 UTC
I'm now on Tumbleweed 20180626 with VirtualBox 5.2.12_SUSE r122571.
Comment 3 Arno Frausenbruck 2018-06-29 14:37:43 UTC
I'm now on Tumbleweed 20180626. The bug is still there.
Comment 4 Arno Frausenbruck 2018-06-29 14:38:11 UTC
(In reply to Arno Frausenbruck from comment #3)
> I'm now on Tumbleweed 20180626. The bug is still there.

Sorry, 20180627 of course. :)
Comment 5 Larry Finger 2018-06-29 15:25:29 UTC
I saw this problem a couple of times, but it was transient as a reboot brought back the desktop that I expected. It has been at least two weeks since it happened to me.

Some critical information is missing:
1. What is the host OS and VB version?
2. What desktop is the guest running?
Comment 6 Arno Frausenbruck 2018-06-29 16:42:11 UTC
(In reply to Larry Finger from comment #5)
> Some critical information is missing:
> 1. What is the host OS and VB version?

I gave both information above: openSUSE Tumbleweed 20180627, VirtualBox 5.2.12_SUSE r122571.

Please note that only the GUI is affected, not the window(s) with the guest OS. So ...

> 2. What desktop is the guest running?

... I'm not running any guest. The program "VirtualBox" has the bug.
Comment 7 Larry Finger 2018-06-29 17:21:02 UTC
I completely misinterpreted what you meant by "Status bar"? Perhaps, you had better post a screen shot showing exactly what you mean.
Comment 8 Wolfgang Bauer 2018-06-29 17:41:12 UTC
It's caused by a regression in Qt 5.11.1, this should fix it:
https://api.opensuse.org/request/show/619726

Btw, it only happens if you close the window via the close button.
Choose "Quit" from the menu to avoid the problem...
Comment 9 Arno Frausenbruck 2018-06-29 21:17:49 UTC
(In reply to Larry Finger from comment #7)
> I completely misinterpreted what you meant by "Status bar"? Perhaps, you had
> better post a screen shot showing exactly what you mean.

Yes, it's the regression mentioned by Wolfgang Bauer, thanks for the hint! [Ctrl+q] seems to work too.

(I thought the description was clear enough, especially with the reference to the configuration file ;-) )
Comment 10 Larry Finger 2018-07-02 00:42:39 UTC
This bug was a problem with Qt 5.11.1, which is not=w fixed.