Bug 1091522

Summary: wine game graphics layout broken in fullscreen
Product: [openSUSE] openSUSE Tumbleweed Reporter: Stefan Sauer <ensonic>
Component: OtherAssignee: Marcus Meissner <meissner>
Status: RESOLVED UPSTREAM QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None    
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: screenshot of a game
wine gfx settings

Description Stefan Sauer 2018-05-01 11:25:55 UTC
Created attachment 768729 [details]
screenshot of a game

Previously games worked fine in full-screen. Since about a month they don't (just updated to Tumbleweed 20180427. I've downgraded playonlinux and wine, but neither helped.

Let me try to describe the issues using the attached screenshot. Imagine the image to be dived into 3x3.

1: The mouse is caught in the upper left box and only moves along the border. That is, I can't e.g. move the mouse into the middle of the upper left field.

2: The graphics that are shown in the middle of the 3x3 grid are what is supposed to be shows full-screen.

If I run the game in windowed mode, the graphics are okay, but are tiny (since the screen is 2560x1440 and the game is 1024x768).

sudo lspci -nnk | grep -A3 VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon RX 550] [1002:699f] (rev c7)
	Subsystem: Sapphire Technology Limited Lexa PRO [Radeon RX 550] [1da2:e367]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
Comment 1 Stefan Sauer 2018-05-01 11:29:53 UTC
Created attachment 768730 [details]
wine gfx settings

With the "emulate a virtual desktop" it works, but it is shown in a 1024x768 window
Comment 2 Stefan Sauer 2018-08-10 11:42:09 UTC
So is wine trying to switch screenmodes in a way that is not supported anymore?

It looks like it is drawing into a buffer that is for sure not the resosultion is way expecting it to have. On the other hand if it would only be the buffer size one would see artifacts of bad strides, but those are not present.
Comment 3 Stefan Sauer 2018-08-10 14:19:06 UTC
aaaa! If I use gnome under Xorg it works. If I use gnome via Wayland it does not!

Now if only I knew that you opensuse gratuitously switched the default without telling me :/

So is there anything to set/configure/try to convince Xwayland to behave?

Maybe related to https://bugzilla.redhat.com/show_bug.cgi?id=1289714
Comment 4 Marcus Meissner 2018-08-20 11:50:47 UTC
I actually do not know. :/

this is a bit above my head and needs upstream wayland and probably also wine work.

it seems the workaround with using Xorg is working well here, so that can be used until upstream has the rest of the things in place.