Bug 1087763

Summary: Installer doesn't create @ volumes when not using suggested partitioning schem
Product: [openSUSE] openSUSE Tumbleweed Reporter: Christian Boltz <suse-beta>
Component: InstallationAssignee: YaST Team <yast-internal>
Status: RESOLVED FIXED QA Contact: Jiri Srain <jsrain>
Severity: Normal    
Priority: P2 - High CC: jlopez
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: openSUSE Factory   
URL: https://trello.com/c/wifz8OmW
Whiteboard:
Found By: Beta-Customer Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Christian Boltz 2018-04-02 15:25:18 UTC
Bug 1077866 fixed using the correct list of subvolumes, but it still doesn't prepend the volume names with "@/" (tested with the Tumbleweed DVD downloaded 3 days ago)

Reproducer:
- boot Tumbleweed DVD and start the installation, click through until you reach 
  the partitioning proposal
- check the default btrfs layout, it contains subvolumes like "@/var" as expected
- click "Expert Partitioner" - "Start with existing partitions"
- add a new partition, 50 GB, select role "operating system" - this should create
  a btrfs partition for /
- click "Subvolume Handling" (or continue until you reach the partitioning summary 
  screen), and you'll notice the subvolumes are named "var" instead of "@/var"

This looks like an obvious case, so I won't attach y2logs for now. If you really need the logs, tell me, and I'll try to extract them from the VM ;-)
Comment 1 Steffen Winterfeldt 2018-04-03 11:25:16 UTC
Tracking in YaST scrum board.
Comment 2 José Iván López González 2018-04-11 14:26:28 UTC
Fixed with yast2-storage-ng >= 4.0.153.

SR: https://build.suse.de/request/show/161612