Bug 1085364

Summary: KIO is forgetting last used directory on remote file dialogs
Product: [openSUSE] openSUSE Distribution Reporter: Howard Richardson <68guns>
Component: KDE ApplicationsAssignee: E-Mail List <opensuse-kde-bugs>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: wbauer
Version: Leap 42.3   
Target Milestone: ---   
Hardware: x86-64   
OS: openSUSE 42.3   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Howard Richardson 2018-03-14 19:25:12 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build Identifier: 

On all KDE applications the file selection dialogs (eg. for open file) are forgetting the last used directory, if that last used directory is remote - for instance over SFTP using a KIO slave.

Previous to Leap 42.3 it would always remember the last open directory, so for instance if you open one file on a remote SFTP server, the next time you click open will open from the same directory.

Instead it is dumping you back in your local home directory every time, regardless of the context. This makes for a tedious navigation back to a particular remote directory location, especially if it is deep down a directory tree.

Reproducible: Always

Steps to Reproduce:
1. In Kate (for instance) open a remote file on a SFTP server.
2. Once opened, click open again.
3. See where the starting point is for browsing the filesystem.
Actual Results:  
The second time you click open, instead of remembering the last used directory of this context, namely the remote SFTP directory, it dumps you back into you local home directory instead.

Expected Results:  
The software should start the filesystem browsing from the same directory as houses the currently open file. This is what happened on all versions of Leap prior to 42.3.
Comment 1 Wolfgang Bauer 2018-03-14 19:36:58 UTC
AFAIK, this is application dependent, i.e. the application should tell KIO which directory to use as a start.

In any way, it's not openSUSE specific, please report it upstream at https://bugs.kde.org/ and maybe report back the bug number.

Thanks.
Comment 2 Howard Richardson 2018-03-14 22:07:52 UTC
Thanks. Have reported to bugs.kde here:
https://bugs.kde.org/show_bug.cgi?id=391869
Comment 3 Wolfgang Bauer 2018-04-18 08:38:59 UTC
So this actually was caused by a change in Qt 5.7.1 (that apparently got backported to 5.6.2 as well).

A fix for it has been added to plasma-integration recently though. (it's actually Plasma's platform plugin that sets the wrong directory, and even overriding what Qt would correctly use since that change)

I'll add the fix to our packages, and also submit an update to Leap 42.3.

For now, you can use the plasma5-integration-plugin package from here, if you want:
https://download.opensuse.org/repositories/home:/wolfi323:/branches:/OBS_Maintained:/plasma5-integration/openSUSE_Leap_42.3_Update
Comment 4 Swamp Workflow Management 2018-04-24 09:40:12 UTC
This is an autogenerated message for OBS integration:
This bug (1085364) was mentioned in
https://build.opensuse.org/request/show/600316 42.3+Backports:SLE-12-SP3 / plasma5-integration
Comment 5 Swamp Workflow Management 2018-04-26 22:07:09 UTC
openSUSE-RU-2018:1092-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1085364
CVE References: 
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    plasma5-integration-5.9.4-8.1
Comment 6 Swamp Workflow Management 2018-04-26 22:11:42 UTC
openSUSE-RU-2018:1097-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1085364
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    plasma5-integration-5.9.4-4.6.1
Comment 7 Wolfgang Bauer 2018-04-27 12:49:39 UTC
Update released for 42.3 as well, so closing as fixed.