Bug 1081478

Summary: Package "paperwork" has incorrect dependencies, failed to start initially
Product: [openSUSE] openSUSE Tumbleweed Reporter: Boian Berberov <bberberov+suse>
Component: OtherAssignee: Bjørn Lie <bjorn.lie>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: jubalh, matthias
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Boian Berberov 2018-02-18 21:52:26 UTC
I installed the package "paperwork" from the Tumbleweed repo and initially it failed to start.  After some investigation I discovered that it was missing the package "python2-Whoosh".  When looking at the dependencies through Yast2, it looks like the list is outdated.  For example, there is no "pypoppler" or "poppler" in the Tumbleweed repo.
Comment 1 Andreas Stieger 2018-02-19 07:31:11 UTC
assign to maintainers
Comment 3 Boian Berberov 2018-02-20 18:52:49 UTC
The version I have installed is 0.3.2-1.6

It's from: http://download.opensuse.org/tumbleweed/repo/oss/
I don't know how else to identify a repo.

This is the last line in the Change Log in Yast:
Sun 25 Dec 2016 06:00:00 AM CST
mailaender@opensuse.org
- use gobject-introspection instead of requiring the typelibs

From the Dependencies tab in Yast (had to reformat):
========================================
Installed Version
-----------------

Version: 0.3.2-1.6

Provides:
---------
application()
application(paperwork.desktop)
paperwork = 0.3.2-1.6

Prerequires:
------------
/bin/sh
/bin/sh

Requires:
---------
typelib(GLib)
typelib(GObject)
/usr/bin/python
typelib(Gio)
typelib(Pango)
typelib(Gdk)
typelib(GdkPixbuf)
python-gobject
poppler
python-Pillow
python-pip
python-Levenshtein
python-pycountry
python-pyocr
python-scipy
python-simplebayes
python-termcolor
pypoppler
python-enchant
python-gobject-cairo
python-pyinsane
python-whoosh
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
python(abi) = 2.7
typelib(Gtk) = 3.0
typelib(PangoCairo) = 1.0
typelib(Poppler) = 0.18
/bin/sh
/bin/sh

Recommends:
-----------
sane-backends
tesseract-ocr

========================================

That repo does not have:
- poppler
- python-whoosh
- pypoppler
... and probably others from the list above.

These are the names I found:
- poppler-data and poppler-tools
- python2-Whoosh
- python-poppler (will probably change to python2-poppler based on recent renaming trends)

It failed to start when I initially installed it and I think this should be corrected.  You could remove it if it shouldn't be in Tumbleweed anymore.
Comment 4 Matthias Mailänder 2019-09-03 14:05:34 UTC
According to https://build.opensuse.org/package/view_file/openSUSE:Factory/paperwork/paperwork.changes?expand=1 this should be already resolved.
Comment 5 Matthias Mailänder 2019-09-03 14:06:07 UTC
https://build.opensuse.org/request/show/682358
Comment 6 Matthias Mailänder 2019-09-03 14:06:22 UTC
https://build.opensuse.org/request/show/682358