Bug 1079049

Summary: Packet yast2-trans should be build with the newest translations
Product: [openSUSE] openSUSE Tumbleweed Reporter: Freek de Kruijf <freek>
Component: YaST2Assignee: E-mail List <yast2-maintainers>
Status: RESOLVED UPSTREAM QA Contact: Jiri Srain <jsrain>
Severity: Normal    
Priority: P5 - None CC: ancor, cwh, sbrabec
Version: CurrentFlags: ancor: needinfo? (cwh)
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Freek de Kruijf 2018-02-02 11:50:30 UTC
During installation of Tumbleweed or Leap 15.0 Beta, choosing to copy users from another system, Yast gives an error. One has to go back and choose one user to copy, the installation will be possible. The cause is a wrong translation in the Dutch translation which has been fixed already many weeks ago. So the packet yast2-trans needs to be rebuild with the newest translations from Weblate.
Comment 1 Ancor Gonzalez Sosa 2018-02-02 12:42:28 UTC
Christopher, Stanislav, do you guys know how are these requests generated?

https://build.opensuse.org/request/show/557087


That's the last one I see and it's two months old. In the yast-translation repository it is mentioned that updates are submitted to OBS by Jenkins, but I see nothing related to yast2-trans at ci.opensuse.org
Comment 2 Stanislav Brabec 2018-02-02 20:07:09 UTC
This request was generated manually, and manually pushed by lslezak (the project does not allow submit requests).

It should happen automatically, and it really happened in past, but now it is broken. I suspect that it is broken by the logic: If version changes, submit request is created. But yast-translations git repo does not contain spec file, so version never changes.

Maybe we should add spec and changes files to the repo, and automatically generate some type of versions (e. g. increment once weekly or so).

There is also a Jenkins task that should automate pushing of pot/po updates in existing projects to yast-translations, but in the autumn it was broken as well. (I do updates manually now. For new modules, manual update is needed anyway.)
Comment 3 Steffen Winterfeldt 2018-04-27 14:09:04 UTC
This made it a yast workshop topic: https://trello.com/c/nx1ktW0a

I'm closing this bug, feel free to discuss on the trello board (or at the workshop).