Bug 1074314

Summary: can't install qbittorrent : nothing provides the dependency libboost_system.so.1.65.1
Product: [openSUSE] openSUSE Tumbleweed Reporter: Luis G <luisangelgonzo>
Component: YaST2Assignee: Luigi Baldoni <aloisio>
Status: RESOLVED FIXED QA Contact: Jiri Srain <jsrain>
Severity: Normal    
Priority: P5 - None CC: 9+suse, dima, kris, oleg.b.antonyan, sor.alexei, virtuousfox, zach
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: openSUSE Factory   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: cmake-3.10.1_boost-1.66.patch

Description Luis G 2018-01-02 10:42:38 UTC
Missing dependencies of qbittorrent (can't install it : tried with zypper and yast)

 libboost_system.so.1.65.1
Comment 1 Luigi Baldoni 2018-01-02 12:49:58 UTC
@Alexei, I'm at loss here.
Any ideas?
Comment 2 Sergey Kondakov 2018-01-03 11:21:12 UTC
It doesn't get rebuilt for its newer dependencies because of inability to find recently updated boost-1.66. Possibly because of https://gitlab.kitware.com/cmake/cmake/issues/17575 which is a problem in cmake.
Comment 3 Luigi Baldoni 2018-01-03 11:43:55 UTC
Does any of the patches listed on that upstream bug page do the trick?
Comment 4 Dmitriy L 2018-01-03 16:23:20 UTC
(In reply to ls gz from comment #0)
> Missing dependencies of qbittorrent (can't install it : tried with zypper
> and yast)
> 
>  libboost_system.so.1.65.1

The lib in the system:
➜  lib64 find . -iname "libboost_system.so.1.65.1" 
./libboost_system.so.1.65.1

➜  lib64 qbittorrent
qbittorrent: symbol lookup error: qbittorrent: undefined symbol: _ZN10libtorrent7session5startEiRKNS_13settings_packEPN5boost4asio10io_serviceE
Comment 5 Sergey Kondakov 2018-01-03 20:30:26 UTC
Created attachment 754731 [details]
cmake-3.10.1_boost-1.66.patch

So, after exhausting number of attempts, I've mashed together a bunch of relevant upstream merge pulls and patches into this file that somehow worked. Now all boost-dependant software finds it and qbittorrent have got successfully rebuilt for me with boost-1.66 and Qt-5.10 which got rid of both aforementioned problems.
Comment 6 Luigi Baldoni 2018-01-03 20:59:28 UTC
Great job!
Comment 7 Oleg Antonyan 2018-01-04 05:13:21 UTC
(In reply to Sergey Kondakov from comment #5)
> Created attachment 754731 [details]
> cmake-3.10.1_boost-1.66.patch
> 
> So, after exhausting number of attempts, I've mashed together a bunch of
> relevant upstream merge pulls and patches into this file that somehow
> worked. Now all boost-dependant software finds it and qbittorrent have got
> successfully rebuilt for me with boost-1.66 and Qt-5.10 which got rid of
> both aforementioned problems.

Thank you
Unfortunately it didn't work for me

oleg@home:~/projects/github/qBittorrent/build (:13210b3e9|✔)
$ /home/oleg/projects/github/cmake/bin/cmake ..
...
-- libtorrent definitions: -DTORRENT_USE_OPENSSL;-DBOOST_ASIO_HASH_MAP_BUCKETS=1021;-DBOOST_EXCEPTION_DISABLE;-DBOOST_ASIO_ENABLE_CANCELIO;-DTORRENT_LINKING_SHARED;-I/usr/include/libtorrent
-- Libtorrent Boost dependencies: system
CMake Error at /home/oleg/projects/github/cmake/Modules/FindBoost.cmake:1931 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.66.0

  Boost include path: /usr/include

  Could not find the following Boost libraries:

          boost_system
Comment 8 Oleg Antonyan 2018-01-04 05:29:56 UTC
(In reply to Oleg Antonyan from comment #7)
> (In reply to Sergey Kondakov from comment #5)
> > Created attachment 754731 [details]
> > cmake-3.10.1_boost-1.66.patch
> > 
> > So, after exhausting number of attempts, I've mashed together a bunch of
> > relevant upstream merge pulls and patches into this file that somehow
> > worked. Now all boost-dependant software finds it and qbittorrent have got
> > successfully rebuilt for me with boost-1.66 and Qt-5.10 which got rid of
> > both aforementioned problems.
> 
> Thank you
> Unfortunately it didn't work for me
> 
> oleg@home:~/projects/github/qBittorrent/build (:13210b3e9|✔)
> $ /home/oleg/projects/github/cmake/bin/cmake ..
> ...
> -- libtorrent definitions:
> -DTORRENT_USE_OPENSSL;-DBOOST_ASIO_HASH_MAP_BUCKETS=1021;-
> DBOOST_EXCEPTION_DISABLE;-DBOOST_ASIO_ENABLE_CANCELIO;-
> DTORRENT_LINKING_SHARED;-I/usr/include/libtorrent
> -- Libtorrent Boost dependencies: system
> CMake Error at /home/oleg/projects/github/cmake/Modules/FindBoost.cmake:1931
> (message):
>   Unable to find the requested Boost libraries.
> 
>   Boost version: 1.66.0
> 
>   Boost include path: /usr/include
> 
>   Could not find the following Boost libraries:
> 
>           boost_system

UPDATE: nope, it worked. my bad. thanks again!
Comment 9 Jacob W 2018-01-05 20:13:22 UTC
*** Bug 1074353 has been marked as a duplicate of this bug. ***
Comment 10 Luigi Baldoni 2018-01-09 15:50:33 UTC
sr#561777 was accepted into Factory.