Bug 1074248

Summary: %posttrans script error
Product: [openSUSE] openSUSE Tumbleweed Reporter: Wolfgang Rosenauer <wolfgang>
Component: OtherAssignee: Johannes Meixner <jsmeix>
Status: RESOLVED DUPLICATE QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: stefan.bruens
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Wolfgang Rosenauer 2017-12-31 11:10:16 UTC
Running Tumbleweed upgrade this came up

Output of ghostscript-fonts-other-9.06-9.1.noarch.rpm %posttrans script:
    /var/adm/update-scripts/posttransPwxQj7/ghostscript-fonts-other-9.06-9.1.noarch.rpmprJNdC: line 23: -n: command not found

Similar/same as Bug 1074245 ? At least it's a different sub package.

posttrans scriptlet (using /bin/sh):

  if [ -e /run/fontpackages/reconfigure-fonts ]; then 
    
  if test -x /usr/sbin/fonts-config ; then 
    LC_ALL=POSIX 
   /usr/sbin/fonts-config --quiet 
  fi 
   
    rm /run/fontpackages/reconfigure-fonts 
  fi 
  if [ -e /run/fontpackages/reconfigure-fonts-cjk ]; then 
    
  if test -x /usr/sbin/acroread-cidfont-config ; then 
     /usr/sbin/acroread-cidfont-config 
  fi 
  if test -x /usr/sbin/ghostscript-cjk-config ; then 
      /usr/sbin/ghostscript-cjk-config 
  fi 
   
    rm /run/fontpackages/reconfigure-fonts-cjk 
  fi 
   -n ghostscript-fonts-other
exit 0

The last line
-n ghostscript-fonts-other
looks like a typo.
Comment 1 Stefan BrĂ¼ns 2018-02-26 18:26:36 UTC
Duplicate of 1074964

*** This bug has been marked as a duplicate of bug 1074964 ***