Bug 1074242

Summary: sane-backends 1.0.27 with canon Lide 100 - Black bar in every scan
Product: [openSUSE] openSUSE Tumbleweed Reporter: Christoph Müller <1984.christoph>
Component: OtherAssignee: Johannes Meixner <jsmeix>
Status: RESOLVED UPSTREAM QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: meissner
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: openSUSE Factory   
URL: https://alioth.debian.org/tracker/?group_id=30186&atid=410366&func=detail&aid=315752
Whiteboard:
Found By: Community User Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Christoph Müller 2017-12-30 12:13:44 UTC
This is my first bug report so please correct me if something is wrong.

The problem is simple:

Reproduce the Bug:
Use an Lide 100 oder Lide 200 scanner and try to scan anything with sane-backends 1.0.27 and you will get a Black bar. The color can vary a bit. I tested skanlite and xsane. The problem seems to entirely with sane-backends.

Solution:

Revert the linked commit:
https://alioth.debian.org/tracker/?group_id=30186&atid=410366&func=detail&aid=315752
Comment 1 Johannes Meixner 2018-04-05 09:11:31 UTC
We do not develop sane-backends.

Please report upstream issues directly to the SANE project at
http://www.sane-project.org/
http://www.sane-project.org/bugs.html

Ideally provide an URL to your upstream issue report
here as reference.
Comment 2 Christoph Müller 2018-05-01 11:45:58 UTC
(In reply to Johannes Meixner from comment #1)
> We do not develop sane-backends.
> 
> Please report upstream issues directly to the SANE project at
> http://www.sane-project.org/
> http://www.sane-project.org/bugs.html
> 
> Ideally provide an URL to your upstream issue report
> here as reference.

Really helpful. I linked the Bug report. I know Opensuse doesn't develop sane-backends. And i linked the Bug report. You really didn't read anything.
Comment 3 Johannes Meixner 2018-05-02 07:51:52 UTC
I did read but it seems you do not understand,
perhaps because I did not explain it (see below).

It seems you do not understand how free software development
versus fee software distribution works and therefore
it seems you have wrong expectations what we (at openSUSE)
can do to fix your particular issue in this particular case.

Explanation:

Because we (at openSUSE) do not develop sane-backends,
we cannot bildly "just revert" a SANE upstream commit
because we do not understand what other consequences
at whatever other places such a change may have.

"Just reverting" a SANE upstream commit can make things
work for your particular case but on the other hand
there is a reason why SANE upstream did that commit
(but I do not understand what the commit message means).

If you want a change of the SANE upstream code
you must get in direct contact with SANE upstream
and work together with the SANE upstream authors
to get your particular case fixed at SANE upstream.

This is the only way how issues can get solved properly.
It cannot work well when each Linux distribution maintains
its own distribution-specific different set of patches.
Only when issues get solved at the upstream projects
things will "just work" for all Linux distributions.

In this case the SANE upstream authors need to get
a better understanding of this issue to find a solution
for their intent behind why they did that commit but
without the bad consequences of the current implementation.

Simply put:

Continue to be helpful and continue to contribute to the
SANE upstream bug report to get this issue solved properly
for you and for all users of those scanner models.
Comment 4 Christoph Müller 2018-05-02 14:44:36 UTC
(In reply to Johannes Meixner from comment #3)
> I did read but it seems you do not understand,
> perhaps because I did not explain it (see below).
> 
> It seems you do not understand how free software development
> versus fee software distribution works and therefore
> it seems you have wrong expectations what we (at openSUSE)
> can do to fix your particular issue in this particular case.
> 
> Explanation:
> 
> Because we (at openSUSE) do not develop sane-backends,
> we cannot bildly "just revert" a SANE upstream commit
> because we do not understand what other consequences
> at whatever other places such a change may have.
> 
> "Just reverting" a SANE upstream commit can make things
> work for your particular case but on the other hand
> there is a reason why SANE upstream did that commit
> (but I do not understand what the commit message means).
> 
> If you want a change of the SANE upstream code
> you must get in direct contact with SANE upstream
> and work together with the SANE upstream authors
> to get your particular case fixed at SANE upstream.
> 
> This is the only way how issues can get solved properly.
> It cannot work well when each Linux distribution maintains
> its own distribution-specific different set of patches.
> Only when issues get solved at the upstream projects
> things will "just work" for all Linux distributions.
> 
> In this case the SANE upstream authors need to get
> a better understanding of this issue to find a solution
> for their intent behind why they did that commit but
> without the bad consequences of the current implementation.
> 
> Simply put:
> 
> Continue to be helpful and continue to contribute to the
> SANE upstream bug report to get this issue solved properly
> for you and for all users of those scanner models.

Thanks for the answer and I'm sorry. 

I just thought you didn't read it because you linked me to the sane bugtracker. I posted a link with the bug of exactly that bugtracker. I read it like you wanted me to report the Issue upstream when i already posted the link to the reported issue. Read like a Robot/Template response.

My custom build in OBS failed where i fixed the problem (reverted the change). Since i no longer have the time to deal with that i switched away from OpenSUSE to a distro where rebuilding a Package is easier.

I understand. But it is also somewhat frustrating to get told to report a Bug on the opensuse Sub, then hear nothing for months and thats it. But that is my issue and has nothing to do with this.
Comment 5 Johannes Meixner 2018-05-02 15:03:16 UTC
I can fully understand how things went wrong here.
Unfortunately I find almost no time to work on scanner issues
so that such annoyingly long delays do happen and will happen.