Bug 1070879

Summary: [20171201] Non-UTF8 locale set on live medium
Product: [openSUSE] openSUSE Tumbleweed Reporter: Dominique Leuenberger <dimstar>
Component: BasesystemAssignee: Dominique Leuenberger <dimstar>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: fabian
Version: Current   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Dominique Leuenberger 2017-12-02 11:28:18 UTC
A recent change introduced a different LANG setting on the live medium, which in turn causes

Dec 02 10:53:11 susetest gnome-terminal-server[4163]: Non UTF-8 locale (ANSI_X3.4-1968) is not supported!

The only thing I can think of right now is https://build.opensuse.org/request/show/546805 which might influence this
Comment 1 Fabian Vogt 2017-12-02 12:19:41 UTC
langset still works as expected: 

"Dec 02 10:40:02 localhost systemd[1]: Started Adjust the system language based on the kernel cmdline."

I would rather say that https://build.opensuse.org/request/show/546407 broke it - a fix is already submitted as https://build.opensuse.org/request/show/547234
Comment 2 Dominique Leuenberger 2017-12-02 12:24:01 UTC
(In reply to Fabian Vogt from comment #1)
> langset still works as expected: 
> 
> "Dec 02 10:40:02 localhost systemd[1]: Started Adjust the system language
> based on the kernel cmdline."
> 
> I would rather say that https://build.opensuse.org/request/show/546407 broke
> it - a fix is already submitted as
> https://build.opensuse.org/request/show/547234

Also an option - I did not consider that one because the issue only hit the Live Media, the 'real' install does not suffer from that issue (which made me look at 'live image specific things')
Comment 3 Dominique Leuenberger 2017-12-08 14:29:11 UTC
(In reply to Dominique Leuenberger from comment #2)
> (In reply to Fabian Vogt from comment #1)
> > langset still works as expected: 
> > 
> > "Dec 02 10:40:02 localhost systemd[1]: Started Adjust the system language
> > based on the kernel cmdline."
> > 
> > I would rather say that https://build.opensuse.org/request/show/546407 broke
> > it - a fix is already submitted as
> > https://build.opensuse.org/request/show/547234
> 
> Also an option - I did not consider that one because the issue only hit the
> Live Media, the 'real' install does not suffer from that issue (which made
> me look at 'live image specific things')

The aaa_base fix was checked in to snapshot 1206 and openQA passes the tests there again.